summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-24 23:56:51 -0400
committerMark H Weaver <mhw@netris.org>2018-03-25 05:01:53 -0400
commit5e6c882e2d2e050166ba1d4d38f45e28660b7644 (patch)
tree364588f06f970feffd02d995ab6b742f9a418888 /gnu
parent5cdad3ee86dd40ac6b7ba07ee038245fbed39e96 (diff)
downloadguix-5e6c882e2d2e050166ba1d4d38f45e28660b7644.tar.gz
gnu: wireless-regdb: Inhibit gzip timestamp.
* gnu/packages/linux.scm (wireless-regdb)[arguments]: Add 'gzip-determinism'
phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 95c609201c..c02084f52f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2263,6 +2263,11 @@ compliance.")
     (build-system gnu-build-system)
     (arguments
      '(#:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'gzip-determinism
+                    (lambda _
+                      (substitute* "Makefile"
+                        (("gzip") "gzip --no-name"))
+                      #t))
                   (delete 'configure))
 
        ;; The 'all' target of the makefile depends on $(REGDB_CHANGED), which