summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-01-10 18:18:17 +0100
committerLudovic Courtès <ludo@gnu.org>2017-01-10 22:15:26 +0100
commit74d212911e6de68cdea0d2d88fcf63ca3a193846 (patch)
treecd500bbfa71d5e20a094e82f5987625cc01a8213 /gnu
parent6d3e08d4e83ecadf67d0f338947e960f61c9a6a4 (diff)
downloadguix-74d212911e6de68cdea0d2d88fcf63ca3a193846.tar.gz
gnu: e2fsprogs: Use symlinks instead of hard links.
* gnu/packages/linux.scm (e2fsprogs)[arguments]: Pass
"--enable-symlink-install".
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 117ad55850..b7cbba4d10 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
 ;;; Copyright © 2014, 2015, 2016, 2017 Mark H Weaver <mhw@netris.org>
@@ -641,6 +641,11 @@ slabtop, and skill.")
                            "--disable-libuuid" "--disable-uuidd"
                            "--disable-fsck"
 
+                           ;; Use symlinks instead of hard links for
+                           ;; 'fsck.extN' etc.  This makes the resulting nar
+                           ;; smaller and is preserved across copies.
+                           "--enable-symlink-install"
+
                            ;; Install libext2fs et al.
                            "--enable-elf-shlibs")