summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-12-03 17:22:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-12-03 18:31:48 +0100
commit75bbc3c2e2403da47bd41eb40c1f6f65101e225c (patch)
tree004dd268cbeb186da8e3b36002a1dd3dc55ae72a /gnu
parenta36047422fedae1629f973a975e08d9c6941d0b4 (diff)
downloadguix-75bbc3c2e2403da47bd41eb40c1f6f65101e225c.tar.gz
gnu: faust-2: Remove inherited phase.
* gnu/packages/audio.scm (faust-2)[arguments]: Remove build phase
"fix-permissions".
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/audio.scm13
1 files changed, 1 insertions, 12 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 2407f00796..78ea3613ae 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1158,18 +1158,7 @@ PS, and DAB+.")
      (substitute-keyword-arguments (package-arguments faust)
        ((#:make-flags flags)
         `(list (string-append "prefix=" (assoc-ref %outputs "out"))
-               "world"))
-       ((#:phases phases)
-        `(modify-phases ,phases
-           ;; Files appear under $out/share/faust that are read-only.  The
-           ;; install phase tries to overwrite them and fails, so we change
-           ;; the permissions first.
-           (add-before 'install 'fix-permissions
-             (lambda* (#:key outputs #:allow-other-keys)
-               (for-each (lambda (file)
-                           (chmod file #o644))
-                         (find-files "architecture/max-msp" ".*"))
-               #t))))))
+               "world"))))
     (native-inputs
      `(("llvm" ,llvm-with-rtti)
        ("which" ,which)