summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-05-23 09:53:08 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-05-23 10:08:20 +0200
commitb2086776f1466cdb8096eec0b75a52fcf169d7cd (patch)
tree37e3a7048c0e8cdbddff1b519d1274a6e5ff056e /gnu
parentaa4818c33b6b2fd8d602ee93a2f53005d9472f41 (diff)
downloadguix-b2086776f1466cdb8096eec0b75a52fcf169d7cd.tar.gz
gnu: gimp-fourier: Fix build.
* gnu/packages/gimp.scm (gimp-fourier)[arguments]: Copy gegl-0.4.pc to
gegl-0.3.pc in the configure phase.
[inputs]: Add gegl.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gimp.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index f2e020b560..08b2d2a43f 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016, 2018 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
@@ -196,7 +196,18 @@ that is extensible via a plugin system.")
      `(#:tests? #f ;no tests
        #:phases
        (modify-phases %standard-phases
-         (delete 'configure)
+         ;; FIXME: The gegl package only installs "gegl-0.4.pc", but
+         ;; "gimp-2.0.pc" requires "gegl-0.3.pc", so we just copy it.
+         (replace 'configure
+           (lambda* (#:key inputs #:allow-other-keys)
+             (mkdir-p "tmppkgconfig")
+             (copy-file (string-append (assoc-ref inputs "gegl")
+                                       "/lib/pkgconfig/gegl-0.4.pc")
+                        "tmppkgconfig/gegl-0.3.pc")
+             (setenv "PKG_CONFIG_PATH"
+                     (string-append "tmppkgconfig:"
+                                    (or (getenv "PKG_CONFIG_PATH") "")))
+             #t))
          (add-after 'unpack 'set-prefix
            (lambda* (#:key outputs #:allow-other-keys)
              ;; gimptool-2.0 does not allow us to install to any target
@@ -215,6 +226,7 @@ that is extensible via a plugin system.")
        ("gimp" ,gimp)
        ;; needed by gimp-2.0.pc
        ("gdk-pixbuf" ,gdk-pixbuf)
+       ("gegl" ,gegl)
        ("cairo" ,cairo)
        ("glib" ,glib)
        ;; needed by gimpui-2.0.pc