summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-10-19 16:27:58 -0400
committerLeo Famulari <leo@famulari.name>2018-10-23 00:18:17 -0400
commitd0ff383ed8368e11edd837aa61e6900ee5237acd (patch)
tree5081b989b6cbe81adc5d9b5055d50b7e7b0e30f9 /gnu
parent844b3272dab2165fd87f26647cac5e53a080c0ce (diff)
downloadguix-d0ff383ed8368e11edd837aa61e6900ee5237acd.tar.gz
gnu: opus-tools: Update to 0.2.
* gnu/packages/xiph.scm (opus-tools): Update to 0.2.
[native-inputs]: Add pkg-config.
[inputs]: Add libopusenc and opusfile. Remove libogg and opus.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xiph.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index f40522730b..8991bfa609 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -355,7 +355,7 @@ incorporated technology from Skype's SILK codec and Xiph.Org's CELT codec.")
 (define opus-tools
   (package
     (name "opus-tools")
-    (version "0.1.10")
+    (version "0.2")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -363,7 +363,7 @@ incorporated technology from Skype's SILK codec and Xiph.Org's CELT codec.")
                     version ".tar.gz"))
               (sha256
                (base32
-                "135jfb9ny3xvd27idsxj7j5ns90lslbyrq70cq3bfwcls4r7add2"))))
+                "11pzl27s4vcz4m18ch72nivbhww2zmzn56wspb7rll1y1nq6rrdl"))))
     (build-system gnu-build-system)
     (arguments
      ;; The package developers misuse pkg-config such that it doesn't work
@@ -374,9 +374,12 @@ incorporated technology from Skype's SILK codec and Xiph.Org's CELT codec.")
                                               "/include -I"
                                               (assoc-ref %build-inputs "opus")
                                               "/include/opus"))))
-    (inputs `(("libogg" ,libogg)
-              ("opus" ,opus)
-              ("flac" ,flac)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libopusenc" ,libopusenc)
+       ("opusfile" ,opusfile)
+       ("flac" ,flac)))
     (synopsis
      "Command line utilities to encode, inspect, and decode .opus files")
     (description "Opus is a royalty-free, highly versatile audio codec.