summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-08-15 23:50:54 +0200
committerLudovic Courtès <ludo@gnu.org>2013-08-15 23:51:52 +0200
commite928da09c99fab6c2b9b7ed869f073bc8b03085f (patch)
tree8ef2353a8ee17e7423255beeb097e8184b1ad83d /gnu
parent3b4f21bd1b7e32dfbf55b5a86d96331415ef0785 (diff)
downloadguix-e928da09c99fab6c2b9b7ed869f073bc8b03085f.tar.gz
gnu: Add Bitstream Vera.
* gnu/packages/xorg.scm (font-bitstream-vera-ttf): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xorg.scm58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 2390447211..0760c93405 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -22,6 +23,9 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system trivial)
+  #:use-module ((gnu packages base)
+                #:select (tar))
   #:use-module (gnu packages bison)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages flex)
@@ -4891,3 +4895,57 @@ emulation to complete hardware acceleration for modern GPUs.")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
     (license license:x11)))
+
+(define-public font-bitstream-vera-ttf
+  (package
+    (name "font-bitstream-vera-ttf")
+    (version "1.10")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "mirror://gnome/sources/ttf-bitstream-vera/"
+                                 version "/ttf-bitstream-vera-"
+                                 version ".tar.bz2"))
+             (sha256
+              (base32
+               "1p3qs51x5327gnk71yq8cvmxc6wgx79sqxfvxcv80cdvgggjfnyv"))))
+    (build-system trivial-build-system)
+    (arguments
+     `(#:modules ((guix build utils))
+       #:builder (begin
+                   (use-modules (guix build utils)
+                                (srfi srfi-26))
+
+                   (let ((tar      (string-append (assoc-ref %build-inputs
+                                                             "tar")
+                                                  "/bin/tar"))
+                         (PATH     (string-append (assoc-ref %build-inputs
+                                                             "bzip2")
+                                                  "/bin"))
+                         (font-dir (string-append %output
+                                                  "/share/fonts/truetype"))
+                         (doc-dir  (string-append %output "/share/doc/"
+                                                  ,name "-" ,version)))
+                     (setenv "PATH" PATH)
+                     (system* tar "xvf" (assoc-ref %build-inputs "source"))
+
+                     (mkdir-p font-dir)
+                     (mkdir-p doc-dir)
+                     (chdir (string-append "ttf-bitstream-vera-" ,version))
+                     (for-each (lambda (ttf)
+                                 (copy-file ttf
+                                            (string-append font-dir "/" ttf)))
+                               (find-files "." "\\.ttf$"))
+                     (for-each (lambda (doc)
+                                 (copy-file doc
+                                            (string-append doc-dir "/" doc)))
+                               (find-files "." "\\.TXT$"))))))
+    (native-inputs `(("source" ,source)
+                     ("tar" ,tar)
+                     ("bzip2" ,bzip2)))
+    (home-page "https://www-old.gnome.org/fonts/")
+    (synopsis "Bitstream Vera sans-serif typeface")
+    (description "Vera is a sans-serif typeface from Bitstream, Inc.  This
+package provides the TrueType (TTF) files.")
+    (license
+     (license:x11-style
+      "https://www-old.gnome.org/fonts/#Final_Bitstream_Vera_Fonts"))))