summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2021-10-14 17:30:09 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-10-17 21:48:37 +0300
commit5a6411f684cc65c4ea30bfbf17bf2deb9d56ba9b (patch)
tree5797e6e0844a401e0446b34b152a354350dad917 /gnu
parente4abf26a0fab51fcd73efc48ae17bebece300cab (diff)
downloadguix-5a6411f684cc65c4ea30bfbf17bf2deb9d56ba9b.tar.gz
gnu: deja-dup: Let deja-dup find duplicity.
* gnome.scm (deja-dup)[phases]: Wrap deja-dup to include duplicity
in PATH.
[inputs]: Add bash-minimal.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5d8840e89a..7ac2ff2ad0 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1773,9 +1773,17 @@ configuration files for the GNOME menu, as well as a simple menu editor.")
            (lambda _
              (substitute* "data/post-install.sh"
                (("gtk-update-icon-cache") "true"))
-             #t)))))
+             #t))
+         (add-after 'install 'wrap-program
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             ;; Add duplicity to the search path
+             (wrap-program (string-append (assoc-ref outputs "out")
+                                          "/bin/deja-dup")
+               `("PATH" ":" prefix
+                 (,(string-append (assoc-ref inputs "duplicity") "/bin")))))))))
     (inputs
-     `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+     `(("bash-minimal" ,bash-minimal)
+       ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
        ("duplicity" ,duplicity)
        ("python" ,python)
        ("python-pygobject" ,python-pygobject)