summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-10-07 15:32:20 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-10-08 05:29:30 +0200
commit9be266116ba274ecf6a66178c17e51414dde3eec (patch)
tree74aac717a0ace6c2f6e90a093c3b5b278c236303 /gnu
parent2608d3ea5b48d5dd3d335f4fdad6d4203933e4ba (diff)
downloadguix-9be266116ba274ecf6a66178c17e51414dde3eec.tar.gz
gnu: me-cleaner: Update to 1.2.
* gnu/packages/flashing-tools.scm (me-cleaner): Update to 1.2.
[arguments]: Remove ‘create-setup.py’ phase.  Add ‘install-documentation’ phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/flashing-tools.scm19
1 files changed, 8 insertions, 11 deletions
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 42ce560ca7..7d5c1cf723 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -413,28 +413,25 @@ Management Engine (ME).  You need to @code{sudo rmmod mei_me} and
 (define-public me-cleaner
   (package
     (name "me-cleaner")
-    (version "1.1")
+    (version "1.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/corna/me_cleaner/"
                                   "archive/v" version ".tar.gz"))
               (sha256
                (base32
-                "1pgwdqy0jly80nhxmlmyibs343497yjzs6dwfbkcw0l1gjm8i5hw"))
+                "0hdnay1ai0r6l69z63jkiz6yfwdsqc2mrfyj77hgadv7xxxqm6na"))
               (file-name (string-append name "-" version ".tar.gz"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'create-setup.py
-           (lambda _
-             (call-with-output-file "setup.py"
-               (lambda (port)
-                 (format port "\
-from setuptools import setup
-setup(name='me_cleaner', version='~a', scripts=['me_cleaner.py'])
-" ,version)))
-             #t)))))
+         (add-after 'install 'install-documentation
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (man (string-append out "/share/man/man1")))
+               (install-file "man/me_cleaner.1" man)
+               #t))))))
     (home-page "https://github.com/corna/me_cleaner")
     (synopsis "Intel ME cleaner")
     (description "This package provides tools for disabling Intel