summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-07-29 13:51:04 +0200
committerMarius Bakke <marius@gnu.org>2021-07-29 14:10:13 +0200
commitcdd3141f195f7e9527988f35cc1066475a7ac40d (patch)
treef8dec27424a62553acea2025a09cb4c18bf8fafa /gnu
parentec0a2444176bef974809c15ad4c6acb7f5423ac1 (diff)
downloadguix-cdd3141f195f7e9527988f35cc1066475a7ac40d.tar.gz
gnu: util-linux: Remove cross-compilation workaround.
* gnu/packages/linux.scm (util-linux)[arguments]: Look for /etc/services in
both NATIVE-INPUTS and INPUTS, instead of by input label.  Remove unused variable.
[inputs]: When cross-compiling, don't add NET-BASE.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm15
1 files changed, 5 insertions, 10 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 416d294425..d5ee18081e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1787,13 +1787,13 @@ providing the system administrator with some help in common tasks.")
                           (("\"/bin/umount\"")
                            (string-append "\"" out "/bin/umount\""))))))
                   (add-before 'check 'pre-check
-                    (lambda* (#:key inputs outputs #:allow-other-keys)
-                      (let ((out (assoc-ref outputs "out"))
-                            (net (assoc-ref inputs "net-base")))
+                    (lambda* (#:key native-inputs inputs #:allow-other-keys)
+                      (let ((services (search-input-file (or native-inputs inputs)
+                                                         "etc/services")))
                         ;; Change the test to refer to the right file.
                         (substitute* "tests/ts/misc/mcookie"
                           (("/etc/services")
-                           (string-append net "/etc/services")))
+                           services))
 
                         ;; The C.UTF-8 locale does not exist in our libc.
                         (substitute* "tests/ts/column/invalid-multibyte"
@@ -1837,12 +1837,7 @@ providing the system administrator with some help in common tasks.")
                                                  "\\.pc$")
                           (("^(exec_)?prefix=.*") ""))))))))
     (inputs `(("zlib" ,zlib)
-              ("ncurses" ,ncurses)
-
-              ;; XXX: This is so that the 'pre-check' phase can find it.
-              ,@(if (%current-target-system)
-                    `(("net-base" ,net-base))
-                    '())))
+              ("ncurses" ,ncurses)))
     (native-inputs
      `(("perl" ,perl)
        ("net-base" ,net-base)))         ;for tests