summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2020-03-18 20:59:09 -0500
committerChristopher Baines <mail@cbaines.net>2020-11-21 09:11:11 +0000
commit90eb5dd6b5989eeb5350c785036c53469496e394 (patch)
tree6c298d5db5dcd506dd27dbabef6a82f833db5ec6 /gnu
parent84b00783da6f853a34f79ccce3eae007b534e0db (diff)
downloadguix-90eb5dd6b5989eeb5350c785036c53469496e394.tar.gz
gnu: Add emacs-major-mode-hydra.
* gnu/packages/emacs-xyz.scm (emacs-major-mode-hydra): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 603ac7278b..bab1236995 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7177,6 +7177,20 @@ package @code{emacs-major-mode-hydra} for a user-friendly interface.")
 by side to an Org buffer with your notes relevant to the current page.")
     (license license:gpl3+)))
 
+(define-public emacs-major-mode-hydra
+  (package
+    (inherit emacs-pretty-hydra)
+    (name "emacs-major-mode-hydra")
+    (propagated-inputs
+     `(("emacs-dash" ,emacs-dash)
+       ("emacs-pretty-hydra" ,emacs-pretty-hydra)))
+    (arguments
+     `(#:exclude (cons "^pretty-hydra\\.el" %default-exclude)))
+    (synopsis "Create nice-looking hydras")
+    (description
+     "This package provides the macro @code{pretty-hydra-define} to define
+hydras with one column per group of heads.")))
+
 (define-public emacs-ivy
   (package
     (name "emacs-ivy")