summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2018-01-06 14:13:41 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-01-08 20:27:50 +0800
commitc8cee2ef96b93079d3c629f52a6779d68348227e (patch)
tree661b315e5400a62ae6c5ede385bd265c5f5f3aaa /gnu
parent1e63ecee0b5e1d7e4894af5a51cceeba0092693c (diff)
downloadguix-c8cee2ef96b93079d3c629f52a6779d68348227e.tar.gz
gnu: Add darkstat.
* gnu/packages/monitoring.scm (darkstat): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/monitoring.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index c136265c52..f178232cc3 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -22,6 +23,7 @@
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix build-system perl)
   #:use-module (guix build-system gnu)
+  #:use-module (gnu packages admin)
   #:use-module (gnu packages base)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages gd)
@@ -122,3 +124,35 @@ etc. via a Web interface.  Features include:
   notification and problem history, log file, etc.
 @end itemize\n")
     (license license:gpl2)))
+
+(define-public darkstat
+  (package
+    (name "darkstat")
+    (version "3.0.719")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://unix4lyfe.org/darkstat/darkstat-"
+                                  version ".tar.bz2"))
+              (sha256
+               (base32
+                "1mzddlim6dhd7jhr4smh0n2fa511nvyjhlx76b03vx7phnar1bxf"))))
+    (build-system gnu-build-system)
+    (arguments '(#:tests? #f))          ; no tests
+    (inputs
+     `(("libpcap" ,libpcap)
+       ("zlib" ,zlib)))
+    (home-page "https://unix4lyfe.org/darkstat/")
+    (synopsis "Network statistics gatherer")
+    (description
+     "@command{darkstat} is a packet sniffer that runs as a background process,
+gathers all sorts of statistics about network usage, and serves them over
+HTTP.  Features:
+
+@itemize
+@item Traffic graphs, reports per host, shows ports for each host.
+@item Embedded web-server with deflate compression.
+@item Asynchronous reverse DNS resolution using a child process.
+@item Small.  Portable.  Single-threaded.  Efficient.
+@item Supports IPv6.
+@end itemize")
+    (license license:gpl2)))