summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNoah Landis <noahlandis@posteo.net>2020-11-06 16:39:04 -0700
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-07 10:44:04 +0100
commitd8ef0fe30c7a28d88a2d585e4a487a0d93723047 (patch)
tree6b5a4e6bea1d1ed8596bbca7331251fc10f361eb /gnu
parentd360528512fc8c6bdd51006b8af7c9112d7d8b43 (diff)
downloadguix-d8ef0fe30c7a28d88a2d585e4a487a0d93723047.tar.gz
gnu: Add emacs-monokai-theme.
* gnu/packages/emacs-xyz.scm (emacs-monokai-theme): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 27e99d0e09..bd8543c434 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25310,6 +25310,27 @@ the TypeScript implementation.")
 service.")
       (license license:expat))))
 
+(define-public emacs-monokai-theme
+  (package
+    (name "emacs-monokai-theme")
+    (version "3.5.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/oneKelvinSmith/monokai-emacs")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0dy8c3349j7fmp8052hbgvk0b7ldlv5jqpg0paq1i0hlypivd30i"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/oneKelvinSmith/monokai-emacs")
+    (synopsis "High contrast color theme for Emacs")
+    (description
+     "Monokai theme is a port of the popular TextMate Monokai theme for
+Emacs.")
+    (license license:gpl3+)))
+
 (define-public emacs-nord-theme
   (package
     (name "emacs-nord-theme")