summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-09-19 14:50:23 +0200
committerLudovic Courtès <ludo@gnu.org>2014-09-19 17:23:17 +0200
commitf75426d5b4eb3aa03451cfcd8136968baa1bc167 (patch)
treee16dfb1a469a0eb08d5a785623b95cc6aeef1c8c /gnu
parenta9eef4d2e5607d28b3dd152b8e2fe20516107fb3 (diff)
downloadguix-f75426d5b4eb3aa03451cfcd8136968baa1bc167.tar.gz
gnu: guile-charting: Update to 0.2.0.
* gnu/packages/guile.scm (guile-charting): Update to 0.2.0.  Remove
  now-unnecessary cruft from 'snippet'.  Modify 'godir' in Makefile.in.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile.scm21
1 files changed, 6 insertions, 15 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 787bc16965..906763e924 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -363,30 +363,21 @@ http:://json.org specification. These are the main features:
 (define-public guile-charting
   (package
     (name "guile-charting")
-    (version "0.1.1")
+    (version "0.2.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://wingolog.org/pub/guile-charting/"
                                   "guile-charting-" version ".tar.gz"))
               (sha256
                (base32
-                "1l8xcqq4cp67jzxnmf07ivsgq23mfmi00zz1s8bnv2zkb0ab9475"))
+                "0w5qiyv9v0ip5li22x762bm48g8xnw281w66iyw094zdw611pb2m"))
               (modules '((guix build utils)))
               (snippet
                '(begin
-                  ;; Use the standard versioned location for modules.
-                  (substitute* '("Makefile.in" "charting/Makefile.in")
-                    (("/share/guile/site")
-                     "/share/guile/site/2.0"))
-
-                  ;; Remove dependency from guile-charting.texi to
-                  ;; guile-chartingscmfiles to avoid rebuild the doc (which is
-                  ;; unnecessary and fails with "failed to match any pattern
-                  ;; in form define-macro-with-docs" as of Guile 2.0.11.)
-                  (substitute* "doc/Makefile.in"
-                    (("^(.+):(.*) \\$\\(doc\\)scmfiles(.*$)" _ target
-                      dep1 dep2)
-                     (string-append target ":" dep1 " " dep2 "\n")))))))
+                  ;; Use the standard location for modules.
+                  (substitute* "Makefile.in"
+                    (("godir = .*$")
+                     "godir = $(moddir)\n"))))))
     (build-system gnu-build-system)
     (native-inputs `(("pkg-config" ,pkg-config)))
     (inputs `(("guile" ,guile-2.0)))