summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-06-12 11:34:39 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-06-15 10:36:42 +0200
commit2f6b3d2e7ef7b54c522643b2ddcfd2d08a5de258 (patch)
treeeb7e658e131d378c07e1f9188523bdc197b32183 /gnu
parent719b01c1575b8599b0dca9f245a9d759032f3168 (diff)
downloadguix-2f6b3d2e7ef7b54c522643b2ddcfd2d08a5de258.tar.gz
gnu: python-scikit-learn: Use OpenBLAS instead of ATLAS.
* gnu/packages/python.scm (python-scikit-learn)[inputs]: Replace "atlas" with
  "openblas".
* gnu/packages/python.scm (python-scikit-learn)[arguments]: Remove build phase
  'set-environment-variables, which is only needed when ATLAS is used.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm43
1 files changed, 15 insertions, 28 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 065658fc7c..fcd43d22ab 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2082,35 +2082,22 @@ sources.")
     (arguments
      `(#:phases
        (alist-cons-before
-        'build 'set-environment-variables
-        (lambda* (#:key inputs #:allow-other-keys)
-          (let* ((atlas-threaded
-                  (string-append (assoc-ref inputs "atlas")
-                                 "/lib/libtatlas.so"))
-                 ;; On single core CPUs only the serial library is created.
-                 (atlas-lib
-                  (if (file-exists? atlas-threaded)
-                      atlas-threaded
-                      (string-append (assoc-ref inputs "atlas")
-                                     "/lib/libsatlas.so"))))
-            (setenv "ATLAS" atlas-lib)))
-        (alist-cons-before
-         'check 'set-HOME
-         ;; some tests require access to "$HOME"
-         (lambda _ (setenv "HOME" "/tmp"))
-         ;; Tests can only be run after the library has been installed and not
-         ;; within the source directory.
-         (alist-cons-after
-          'install 'check
-          (lambda _
-            (with-directory-excursion "/tmp"
-              ;; With Python 3 one test of 3334 fails
-              ;; (sklearn.tests.test_common.test_transformers); see
-              ;; https://github.com/scikit-learn/scikit-learn/issues/3693
-              (system* "nosetests" "-v" "sklearn")))
-          (alist-delete 'check %standard-phases))))))
+        'check 'set-HOME
+        ;; some tests require access to "$HOME"
+        (lambda _ (setenv "HOME" "/tmp"))
+        ;; Tests can only be run after the library has been installed and not
+        ;; within the source directory.
+        (alist-cons-after
+         'install 'check
+         (lambda _
+           (with-directory-excursion "/tmp"
+             ;; With Python 3 one test of 3334 fails
+             ;; (sklearn.tests.test_common.test_transformers); see
+             ;; https://github.com/scikit-learn/scikit-learn/issues/3693
+             (system* "nosetests" "-v" "sklearn")))
+         (alist-delete 'check %standard-phases)))))
     (inputs
-     `(("atlas" ,atlas)
+     `(("openblas" ,openblas)
        ("python-nose" ,python-nose)))
     (propagated-inputs
      `(("python-numpy" ,python-numpy)