summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-08-14 16:47:33 +0100
committerLeo Famulari <leo@famulari.name>2016-08-16 14:34:28 -0400
commit3fa2dc27407619326a355bc22637f8f350f1cc89 (patch)
treeb0d6b2aa77a5e732fb7fbfdd743b4c7bd9b91d82 /gnu
parent59c3e984742d20a01493d3ae79e1c2d500c498d9 (diff)
downloadguix-3fa2dc27407619326a355bc22637f8f350f1cc89.tar.gz
gnu: Add python-reportlab.
* gnu/packages/pdf.scm (python-reportlab, python2-reportlab): New
  variables.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/pdf.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 439adb90a1..59e5523c6d 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -5,6 +5,7 @@
 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
 ;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
 ;;; Coypright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;; Coypright © 2016 Marius Bakke <mbakke@fastmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -49,6 +50,7 @@
   #:use-module (gnu packages curl)
   #:use-module (gnu packages pcre)
   #:use-module (gnu packages perl)
+  #:use-module (gnu packages python)
   #:use-module (gnu packages tls)
   #:use-module (srfi srfi-1))
 
@@ -582,3 +584,35 @@ program capable of converting PDF into other formats.")
      "Xournal is an application for notetaking, sketching, keeping a journal
 using a stylus.")
     (license license:gpl2+)))
+
+(define-public python-reportlab
+  (package
+    (name "python-reportlab")
+    (version "3.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "reportlab" version))
+              (sha256
+               (base32
+                "0rz2pg04wnzjjm2f5a8ik9v8s54mv4xrjhv5liqjijqv6awh12gl"))))
+    (build-system python-build-system)
+    (arguments
+     ;; Prevent creation of the egg. Without this flag, various artifacts
+     ;; from the build inputs end up in the final python3 output. It also
+     ;; works around https://debbugs.gnu.org/cgi/bugreport.cgi?bug=20765 .
+     `(#:configure-flags '("--single-version-externally-managed" "--root=/")))
+    (propagated-inputs
+     `(("python-pillow" ,python-pillow)))
+    (home-page "http://www.reportlab.com")
+    (synopsis "Python library for generating PDFs and graphics")
+    (description "This is the ReportLab PDF Toolkit.  It allows rapid creation
+of rich PDF documents, and also creation of charts in a variety of bitmap and
+vector formats.")
+    (license license:bsd-3)
+    (properties `((python2-variant . ,(delay python2-reportlab))))))
+
+(define-public python2-reportlab
+  (package
+    (inherit (package-with-python2
+              (strip-python2-variant python-reportlab)))
+    (native-inputs `(("python2-pip" ,python2-pip)))))