summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-12-29 05:42:16 -0500
committerLeo Famulari <leo@famulari.name>2016-01-15 16:45:24 -0500
commit6720dbb49f2ac8fdffa68a9816a79a4c39b56f65 (patch)
treee81d6a694020315e71ba556229e30fe2a7b1fe07 /gnu
parent848964fe11e26f7d05301b0d496099e960834c5d (diff)
downloadguix-6720dbb49f2ac8fdffa68a9816a79a4c39b56f65.tar.gz
gnu: Add python-pytest-cache.
* gnu/packages/python.scm (python-pytest-cache): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 6f83e3df20..6d9289b3db 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6830,3 +6830,23 @@ minimal and fast API targetting the following uses:
 @end enumerate")
     (home-page "http://codespeak.net/execnet/")
     (license license:expat)))
+
+;;; The software provided by this package was integrated into pytest 2.8.
+(define-public python-pytest-cache
+  (package
+    (name "python-pytest-cache")
+    (version "1.0")
+    (source (origin
+             (method url-fetch)
+             (uri (pypi-uri "pytest-cache" version))
+             (sha256
+              (base32
+               "1a873fihw4rhshc722j4h6j7g3nj7xpgsna9hhg3zn6ksknnhx5y"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-execnet" ,python-execnet)))
+    (synopsis "Py.test plugin with mechanisms for caching across test runs")
+    (description "The pytest-cache plugin provides tools to rerun failures from
+the last py.test invocation.")
+    (home-page "https://bitbucket.org/hpk42/pytest-cache/")
+    (license license:expat)))