summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-07-12 15:48:41 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-08-08 22:08:17 +1000
commit67cc6d7380af0ea594710aeaa06f07272a8a50da (patch)
tree85acbf5c5ca6a3f7bb3538b76ffef8b69ef334ec /gnu
parentb33fdcc488ab4f22c9e9911538bf1412ef71ea5c (diff)
downloadguix-67cc6d7380af0ea594710aeaa06f07272a8a50da.tar.gz
gnu: Add perl-array-utils.
* gnu/packages/perl.scm (perl-array-utils): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 8d4cd1b50b..47bb707444 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -244,6 +244,27 @@ manipulate, read, and write Zip archive files.")
     (home-page "http://search.cpan.org/~phred/Archive-Zip-1.37/lib/Archive/Zip.pm")
     (license (package-license perl))))
 
+(define-public perl-array-utils
+  (package
+    (name "perl-array-utils")
+    (version "0.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/Z/ZM/ZMIJ/Array/Array-Utils-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0w1pwvnjdpb0n6k07zbknxwx6v7y75p4jxrs594pjhwvrmzippc9"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Array-Utils")
+    (synopsis "Small utils for array manipulation")
+    (description "@code{Array::Utils} is a small pure-perl module containing
+list manipulation routines.")
+    (license (package-license perl))))
+
 (define-public perl-base
   (package
     (name "perl-base")