summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-12 20:47:45 +0200
committerDavid Craven <david@craven.ch>2016-08-13 14:07:46 +0200
commita51cdaefbc7a31f3c978629588669aba8bd2c456 (patch)
treeb159dd40dd833210843f8ad862f424d65d3448e2 /gnu
parentd2e4c02d36503ced72e038f57150b559c1920902 (diff)
downloadguix-a51cdaefbc7a31f3c978629588669aba8bd2c456.tar.gz
gnu: kde-frameworks: Add kplotting.
* gnu/packages/kde-frameworks.scm (kplotting): New variable.

Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 619ef58eae..ff16f875dd 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -656,6 +656,44 @@ item models.  It includes views for categorizing lists and to add search filters
 to flat and hierarchical lists.")
     (license (list license:gpl2+ license:lgpl2.1+))))
 
+(define-public kplotting
+  (package
+    (name "kplotting")
+    (version "5.24.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "mirror://kde/stable/frameworks/"
+                            (version-major+minor version) "/"
+                            name "-" version ".tar.xz"))
+        (sha256
+         (base32
+          "0gpypq9kh4b5s6dc7py3m117k3nbxczsfkxgxd9zxvr35kig7ya2"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("xorg-server" ,xorg-server)))
+    (inputs
+     `(("qtbase" ,qtbase)))
+    (arguments
+     `(#:phases
+        (modify-phases %standard-phases
+          (add-before 'check 'start-xorg-server
+            (lambda* (#:key inputs #:allow-other-keys)
+              ;; The test suite requires a running X server.
+              (system (string-append (assoc-ref inputs "xorg-server")
+                                     "/bin/Xvfb :1 &"))
+              (setenv "DISPLAY" ":1")
+             #t)))))
+    (home-page "https://community.kde.org/Frameworks")
+    (synopsis "Data plotting library")
+    (description "KPlotWidget is a QWidget-derived class that provides a virtual
+base class for easy data-plotting.  The idea behind KPlotWidget is that you only
+have to specify information in \"data units\", the natural units of the
+data being plotted.  KPlotWidget automatically converts everything to screen
+pixel units.")
+    (license license:lgpl2.1+)))
+
 (define-public kwindowsystem
   (package
     (name "kwindowsystem")