summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-04-26 16:29:21 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-05-04 12:57:23 +0300
commitc607b7011c55932b46c2279b6fe013d730b78a50 (patch)
tree361ede210e4ee9774ce6bda5069b28d2b05581ae /gnu
parent940f8d39a5a39a7ef1a67323d6a4070440402ab6 (diff)
downloadguix-c607b7011c55932b46c2279b6fe013d730b78a50.tar.gz
gnu: Add pinentry-tty.
* gnu/packages/gnupg.scm (pinentry-tty): New variable.
[arguments]: Add pinentry-tty flag.
(pinentry-gtk2): Inherit from pinentry-tty.
[inputs]: Use gtk+-2, glib for pinentry-gtk2 only.
[description]: Modify description based on inputs.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnupg.scm26
1 files changed, 19 insertions, 7 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 6e16429126..28ab67ce17 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -568,9 +568,9 @@ including tools for signing keys, keyring analysis, and party preparation.
    (license license:gpl2)
    (home-page "http://pgp-tools.alioth.debian.org/")))
 
-(define-public pinentry-gtk2
+(define-public pinentry-tty
   (package
-    (name "pinentry-gtk2")
+    (name "pinentry-tty")
     (version "0.9.7")
     (source (origin
               (method url-fetch)
@@ -580,21 +580,33 @@ including tools for signing keys, keyring analysis, and party preparation.
                (base32
                 "1cp7wjqr6nx31mdclr61s2h84ijqjl0ph99kgj4vyawpjj1j1633"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags '("--enable-pinentry-tty")))
     (inputs
      `(("ncurses" ,ncurses)
        ("libassuan" ,libassuan)
-       ("libsecret" ,libsecret "out")
-       ("gtk+" ,gtk+-2)
-       ("glib" ,glib)))
+       ("libsecret" ,libsecret "out")))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (home-page "https://gnupg.org/aegypten2/")
     (synopsis "GnuPG's interface to passphrase input")
     (description
-     "Pinentry provides a console and a GTK+ GUI that allows users to
-enter a passphrase when `gpg' or `gpg2' is run and needs it.")
+     "Pinentry provides a console that allows users to enter a passphrase when
+@code{gpg} or @code{gpg2} is run and needs it.")
     (license license:gpl2+)))
 
+(define-public pinentry-gtk2
+  (package
+    (inherit pinentry-tty)
+    (name "pinentry-gtk2")
+    (inputs
+     `(("gtk+" ,gtk+-2)
+       ("glib" ,glib)
+       ,@(package-inputs pinentry-tty)))
+    (description
+     "Pinentry provides a console and a GTK+ GUI that allows users to enter a
+passphrase when @code{gpg} or @code{gpg2} is run and needs it.")))
+
 (define-public pinentry
   (package (inherit pinentry-gtk2)
     (name "pinentry")))