summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-09-09 18:30:34 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-09 18:31:05 +0200
commitfe8199a80c1bfded8f1563fd61f1e95ae3ac60fb (patch)
tree4e6afbab64b61641fe630cdc8452f94fedf993a2 /gnu
parent4fb254a3399a62b061fdde365fc8d53d6a6fc23e (diff)
downloadguix-fe8199a80c1bfded8f1563fd61f1e95ae3ac60fb.tar.gz
gnu: openssl: Allow shared objects to be stripped.
* gnu/packages/tls.scm (openssl)[arguments]: Add
  'make-libraries-writable' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tls.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 0bce6e1bc7..e7baa52ec5 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -237,6 +237,16 @@ required structures.")
                                   (string-prefix? "armhf" (%current-system)))
                              '("-mfpu=vfpv3")
                              '()))))))
+        (add-after
+         'install 'make-libraries-writable
+         (lambda* (#:key outputs #:allow-other-keys)
+           ;; Make libraries writable so that 'strip' does its job.
+           (let ((out (assoc-ref outputs "out")))
+             (for-each (lambda (file)
+                         (chmod file #o644))
+                       (find-files (string-append out "/lib")
+                                   "\\.so"))
+             #t)))
         (add-before
          'patch-source-shebangs 'patch-tests
          (lambda* (#:key inputs native-inputs #:allow-other-keys)