summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-09-30 21:20:08 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:12 +0100
commit12ae7cb61aa9010a7d1597c22bca65fdb5bea69c (patch)
tree8dd9e39818cdde42754182331c0c856dbceb2238 /gnu
parentb6e75ce7337dffdab2f99e7a7d6cc76c108d7f7e (diff)
downloadguix-12ae7cb61aa9010a7d1597c22bca65fdb5bea69c.tar.gz
gnu: Add wayland-utils.
* gnu/packages/freedesktop.scm (wayland-utils): New variable.

Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/freedesktop.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 3a4fee5e20..1c510951e9 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1221,6 +1221,29 @@ protocol either in Wayland core, or some other protocol in wayland-protocols.")
                (base32
                 "04vgllmpmrv14x3x64ns01vgwx4hriljayjkz9idgbv83i63hly5"))))))
 
+(define-public wayland-utils
+  (package
+    (name "wayland-utils")
+    (version "1.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.freedesktop.org/wayland/wayland-utils")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "04k1yhyh7h4xawbhpz9pf6cpfmmp1l862fdgsvvnyp4hg9n3j9aj"))))
+    (build-system meson-build-system)
+    (native-inputs (list pkg-config))
+    (inputs (list libdrm wayland wayland-protocols-next))
+    (home-page "https://wayland.freedesktop.org/")
+    (synopsis "Display information about the Wayland protocols")
+    (description "This package provides @code{wayland-info} tool that can be
+used to check which Wayland protocols and versions are advertised by the Wayland
+compositor.")
+    (license license:expat)))
+
 (define-public waylandpp
   (package
     (name "waylandpp")