summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-10-01 17:17:44 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-10-03 21:38:34 +0200
commit3240ddbfb1de54e1139bb6e0f6f86ef70f82ec45 (patch)
treef70a9406d02d838b2464c64a31c39d514521b556 /gnu
parent8e2f3e5e036336482b57b81bc443b0ef892efe5e (diff)
downloadguix-3240ddbfb1de54e1139bb6e0f6f86ef70f82ec45.tar.gz
gnu: Add java-osgi-cmpn.
* gnu/packages/java.scm (java-osgi-cmpn): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index f60198ea08..cd21d790ef 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -4771,3 +4771,34 @@ for use with DataNucleus JPA since the JCP haven't provided an official JPA API
 jar.  See @url{http://java.net/projects/jpa-spec/downloads} for the specification
 used to generate this API.")
     (license (list license:edl1.0 license:epl1.0))))
+
+(define-public java-osgi-cmpn
+  (package
+    (name "java-osgi-cmpn")
+    (version "6.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://central.maven.org/maven2/"
+                                  "org/osgi/osgi.cmpn/" version "/osgi.cmpn-"
+                                  version "-sources.jar"))
+              (sha256
+               (base32
+                "1lmb6xyrmkqdhv1kayf0514rlwq6ypvs4m44ibrck3snp8241wys"))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:jar-name "osgi-cmpn.jar"
+       #:tests? #f)); no tests
+    (inputs
+     `(("annotation" ,java-osgi-annotation)
+       ("core" ,java-osgi-core)
+       ("java-datanucleus-javax-persistence" ,java-datanucleus-javax-persistence)
+       ("microemulator" ,java-microemulator-cldc)
+       ("servlet" ,java-classpathx-servletapi)))
+    (home-page "http://www.osgi.org")
+    (synopsis "Compendium specification module of OSGi framework")
+    (description
+      "OSGi, for Open Services Gateway initiative framework, is a module system
+and service platform for the Java programming language.  This package contains
+the compendium specification module, providing interfaces and classes for use
+in compiling bundles.")
+    (license license:asl2.0)))