summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-09-24 18:28:08 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:14 +0100
commit4033249e2e8482ba1d6270ee21306200e4dd3715 (patch)
tree0bbae3ed4e24c6d04be9718c12796a615f3affaa /gnu
parentb9a0363b22e28373b3075ebf61854e1ec57c85cc (diff)
downloadguix-4033249e2e8482ba1d6270ee21306200e4dd3715.tar.gz
gnu: Add libatcore.
* gnu/packages/kde-utils.scm (libatcore): New variable.

Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-utils.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/kde-utils.scm b/gnu/packages/kde-utils.scm
index d8dc755a98..2657c8aff5 100644
--- a/gnu/packages/kde-utils.scm
+++ b/gnu/packages/kde-utils.scm
@@ -237,6 +237,31 @@ Kate's features include:
       (license ;GPL for programs, LGPL for libraries
                (list license:gpl2+ license:lgpl2.0)))))
 
+(define-public libatcore
+  (let ((commit "0de6393ed3e721537dec50b0ad174d83f1207eb6")
+        (revision "1"))
+    (package
+      (name "libatcore")
+      (version (git-version "1.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://invent.kde.org/libraries/atcore")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1830r6ylpn3l7y2frl8cih5cpjgbkfrib9jq7jklf8aszhlsihf2"))))
+      (build-system qt-build-system)
+      (native-inputs (list extra-cmake-modules))
+      (inputs (list qtcharts qtdeclarative-5 qtserialport))
+      (home-page "https://invent.kde.org/libraries/atcore")
+      (synopsis "Library for connection and management of 3D printers")
+      (description
+       "This package provides a API to manage the serial connection between
+the computer and 3D Printers.")
+      (license (list license:lgpl2.1 license:lgpl3)))))
+
 (define-public wacomtablet
   (package
     (name "wacomtablet")