summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-12-24 01:50:38 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-12-25 23:42:47 +0100
commit467cfaa3fcf4f1d45c07ed0f3ba5d85a079f0fd3 (patch)
treefe3ee541d7b58eab5962ebc15a6c356bc77a8626 /gnu
parentac97dce1d24e3c986c580a76148deafdf52fccdb (diff)
downloadguix-467cfaa3fcf4f1d45c07ed0f3ba5d85a079f0fd3.tar.gz
gnu: Add python-semver.
* gnu/packages/python.scm (python-semver, python2-semver): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 101967a160..7ff1e78bbe 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12144,3 +12144,36 @@ such as figshare or Zenodo.")
                            '("lib/activepapers/builtins3.py"
                              "lib/activepapers/standardlib3.py"
                              "lib/activepapers/utility3.py")))))))))))
+
+(define-public python-semver
+  (package
+    (name "python-semver")
+    (version "2.7.9")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "semver" version))
+        (sha256
+          (base32
+            "0hhgqppchv59rqj0yzi1prdg2nfsywqmjsqy2rycyxm0hvxmbyqz"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-test-requirements
+           (lambda _
+             (substitute* "setup.py"
+               ;; Our Python is new enough.
+               (("'virtualenv<14\\.0\\.0'") "'virtualenv'"))
+             #t)))))
+    (native-inputs
+     `(("python-tox" ,python-tox)
+       ("python-virtualenv" ,python-virtualenv)))
+    (home-page "https://github.com/k-bx/python-semver")
+    (synopsis "Python helper for Semantic Versioning")
+    (description "This package provides a Python library for
+@url{Semantic Versioning, http://semver.org/}.")
+    (license license:bsd-3)))
+
+(define-public python2-semver
+  (package-with-python2 python-semver))