summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-07-19 16:37:40 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-08-10 14:27:26 +0200
commit655e1a474f061556917d4d8bb7f19b0fbe175147 (patch)
tree662d8fc2b2dc3412226a448dcf06033dd33f9ade /gnu
parent4e4c9e064c013e2e3fbccadfcc7e3352683d184d (diff)
downloadguix-655e1a474f061556917d4d8bb7f19b0fbe175147.tar.gz
gnu: Add trytond-product-image-attribute.
* gnu/packages/tryton.scm (trytond-product-image-attribute): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tryton.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 833c157689..9df1d9846b 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2369,6 +2369,27 @@ cost price of products to be calculated separately for each warehouse.")
 product and variant.")
     (license license:gpl3+)))
 
+(define-public trytond-product-image-attribute
+  (package
+    (name "trytond-product-image-attribute")
+    (version "6.2.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "trytond_product_image_attribute" version))
+              (sha256
+               (base32 "1ywyh158325v461qkka5svp4gygsfkkrxd6yl9dgfgypd483qjs8"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "trytond_product_image_attribute"))
+    (native-inputs (%standard-trytond-native-inputs))
+    (propagated-inputs (list trytond trytond-product
+                             trytond-product-attribute
+                             trytond-product-image))
+    (home-page "https://docs.tryton.org/projects/modules-product-image-attribute")
+    (synopsis "Tryton module to select variant images based on attributes")
+    (description "The @emph{Product Image Attribute} Tryton module adds
+attributes to product images.")
+    (license license:gpl3+)))
+
 (define-public trytond-product-kit
   (package
     (name "trytond-product-kit")