summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-19 16:54:26 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-19 17:56:37 +0200
commit7b5b8c44050c459eb94998ac6a0ece204bcc5a04 (patch)
tree9eeac48a3850f856b728d4f8c90106d0a0f7388f /gnu
parenta3bdddc359643a9a32e78e32b919390041818c49 (diff)
downloadguix-7b5b8c44050c459eb94998ac6a0ece204bcc5a04.tar.gz
gnu: Add sbcl-cl-cffi-gtk-gdk.
* gnu/packages/lisp.scm (sbcl-cl-cffi-gtk-gdk): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index b63a55f4ac..ac1d4a432f 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -3397,3 +3397,30 @@ is a library for creating graphical user interfaces.")
                (("libgdk_pixbuf" all)
                 (string-append
                  (assoc-ref inputs "gdk-pixbuf") "/lib/" all))))))))))
+
+(define-public sbcl-cl-cffi-gtk-gdk
+  (package
+    (inherit sbcl-cl-cffi-gtk-boot0)
+    (name "sbcl-cl-cffi-gtk-gdk")
+    (inputs
+     `(("gtk" ,gtk+)
+       ("cl-cffi-gtk-gobject" ,sbcl-cl-cffi-gtk-gobject)
+       ("cl-cffi-gtk-gio" ,sbcl-cl-cffi-gtk-gio)
+       ("cl-cffi-gtk-gdk-pixbuf" ,sbcl-cl-cffi-gtk-gdk-pixbuf)
+       ("cl-cffi-gtk-cairo" ,sbcl-cl-cffi-gtk-cairo)
+       ("cl-cffi-gtk-pango" ,sbcl-cl-cffi-gtk-pango)
+       ,@(package-inputs sbcl-cl-cffi-gtk-boot0)))
+    (arguments
+     `(#:asd-file "gdk/cl-cffi-gtk-gdk.asd"
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-paths
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "gdk/gdk.init.lisp"
+               (("libgdk" all)
+                (string-append
+                 (assoc-ref inputs "gtk") "/lib/" all)))
+             (substitute* "gdk/gdk.package.lisp"
+               (("libgtk" all)
+                (string-append
+                 (assoc-ref inputs "gtk") "/lib/" all))))))))))