summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-11-08 20:56:04 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-11-24 14:52:56 -0500
commit9381e14536cf4370ab1f567839636f21c3eb9f12 (patch)
tree848d4f271393567028a23cda0dd314d1031aa12a /gnu
parent8f3e10ae819aabbe8216bfee6cd3e7857bc27293 (diff)
downloadguix-9381e14536cf4370ab1f567839636f21c3eb9f12.tar.gz
gnu: Add qttranslations.
* gnu/packages/qt.scm (qttranslations): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/qt.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 30bf429897..3784d01eaf 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1878,6 +1878,27 @@ that helps in Qt development.")
     ;; LICENSES/Qt-GPL-exception-1.0.txt).
     (license (list license:gpl3))))
 
+(define-public qttranslations
+  (package
+    (name "qttranslations")
+    (version "6.3.1")
+    (source (origin
+              (method url-fetch)
+              (uri (qt-urls name version))
+              (sha256
+               (base32
+                "15yvvxw1vngnjlly6cady05ljamg01qiaqn2vh0xkph855gdbgfp"))))
+    (build-system cmake-build-system)
+    (arguments (list #:tests? #f))
+    (native-inputs (list qtbase qttools))
+    (home-page (package-home-page qtbase))
+    (synopsis "Qt translation catalogs")
+    (description "This package contains the translations for Qt contributed by
+the Qt community.")
+    ;; GPL 3 only with Qt GPL exception 1.0 (see:
+    ;; LICENSES/Qt-GPL-exception-1.0.txt).
+    (license (list license:gpl3))))
+
 (define-public qtscript
   (package (inherit qtsvg-5)
     (name "qtscript")