summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-06-02 16:35:58 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-06-03 10:41:21 +0200
commitc0b190910668f808e9124f912c127da3cc850a82 (patch)
tree44add7ac9cf8d8368ee6be070af2f9b7a54b0578 /gnu
parent458ee7dcf071f3f37980aab43a7f22e5d76f9ea1 (diff)
downloadguix-c0b190910668f808e9124f912c127da3cc850a82.tar.gz
gnu: Add Data::Stag.
* gnu/packages/perl.scm (perl-data-stag): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 3810f4e1c2..e5ec25e418 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1118,6 +1118,30 @@ on one page.  This results in wanting to page through various pages of data.
 The maths behind this is unfortunately fiddly, hence this module.")
     (license (package-license perl))))
 
+(define-public perl-data-stag
+  (package
+    (name "perl-data-stag")
+    (version "0.14")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/C/CM/CMUNGALL/"
+                           "Data-Stag-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0ncf4l39ka23nb01jlm6rzxdb5pqbip01x0m38bnvf1gim825caa"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-io-string" ,perl-io-string)))
+    (home-page "http://search.cpan.org/dist/Data-Stag")
+    (synopsis "Structured tags datastructures")
+    (description
+     "This module is for manipulating data as hierarchical tag/value
+pairs (Structured TAGs or Simple Tree AGgreggates).  These datastructures can
+be represented as nested arrays, which have the advantage of being native to
+Perl.")
+    (license (package-license perl))))
+
 (define-public perl-data-stream-bulk
   (package
     (name "perl-data-stream-bulk")