summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-08-09 23:33:50 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-08-10 15:44:19 +0200
commitd49bbd01e10e2f19ec3d8a06b31b828ffd2d45de (patch)
tree9dab4295299485f6b9e2961c9d6ed303487eea0b /gnu
parentd9a0ccf13f461335bd23abebeec7af981cae7be8 (diff)
downloadguix-d49bbd01e10e2f19ec3d8a06b31b828ffd2d45de.tar.gz
gnu: Add r-interp.
* gnu/packages/cran.scm (r-interp): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index fc793e3c92..605b722975 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10855,6 +10855,29 @@ supported classes are those defined in packages @code{network} and
 @code{igraph}.")
     (license license:gpl3)))
 
+(define-public r-interp
+  (package
+    (name "r-interp")
+    (version "1.1-3")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "interp" version))
+              (sha256
+               (base32
+                "0gzsnlg8f7knb100n6vv6307c3v2jd8f9qzrq62jkc6g71mn0kmp"))))
+    (properties `((upstream-name . "interp")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-deldir r-rcpp r-rcppeigen))
+    (native-inputs (list gfortran))
+    (home-page "https://cran.r-project.org/package=interp")
+    (synopsis "Interpolation methods")
+    (description
+     "Bivariate data interpolation on regular and irregular grids, either
+linear or using splines are the main part of this package.  It is intended to
+provide replacement functions for the ACM licensed @code{akima::interp} and
+@code{tripack::tri.mesh} functions.")
+    (license license:gpl2+)))
+
 (define-public r-abcoptim
   (package
     (name "r-abcoptim")