summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-07-27 17:49:57 -0400
committerLeo Famulari <leo@famulari.name>2017-07-30 20:10:40 -0400
commit9ad78b2c21738e853986281a5051158fe39d8435 (patch)
tree4d8d9ef10a8627f7a9eb9f116061e775023d953c /gnu
parent721fd1779766deb350f5d9b114d6ba167523b9ec (diff)
downloadguix-9ad78b2c21738e853986281a5051158fe39d8435.tar.gz
gnu: Add perl-test2-bundle-extended.
* gnu/packages/perl.scm (perl-test2-bundle-extended): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index bddcab57d5..54f57a7cb7 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -6473,6 +6473,34 @@ screen size, and retrieval/modification of the control characters.")
 into tables.")
     (license (package-license perl))))
 
+(define-public perl-test2-bundle-extended
+  (package
+    (name "perl-test2-bundle-extended")
+    (version "0.000072")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "mirror://cpan/authors/id/E/EX/EXODIST/Test2-Suite-"
+                            version ".tar.gz"))
+        (sha256
+         (base32
+          "0hgd6n29qjh1pwqvbglm2kb852yqshmixqqjhsr2kvvibdr58qpf"))))
+    (build-system perl-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'set-env
+           (lambda _ (setenv "PERL_USE_UNSAFE_INC" "1"))))))
+    (propagated-inputs
+     `(("perl-importer" ,perl-importer)
+       ("perl-term-table" ,perl-term-table)
+       ("perl-sub-info" ,perl-sub-info)))
+    (home-page "http://search.cpan.org/~exodist/Test2-Suite/lib/Test2/Bundle/Extended.pm")
+    (synopsis "Full set of tools for Test2::Suite")
+    (description "This package provides a rich set of tools, plugins, bundles,
+etc built upon the Test2 testing library.")
+    (license (package-license perl))))
+
 (define-public perl-test-base
   (package
     (name "perl-test-base")