summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-04-29 22:19:25 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-04-30 00:05:14 +0200
commita6559240098d8b8ff7f799f57aecf96a53a88401 (patch)
tree3bb75345bcf7b586a17d1d28076bf6038f0562c2 /gnu
parent37130eccd23eccfdc6653c3e73321fea4000d51d (diff)
downloadguix-a6559240098d8b8ff7f799f57aecf96a53a88401.tar.gz
gnu: Replace python-pyflakes-0.8.1 with python-pyflakes-1.2.
* gnu/packages/python-xyz.scm (python-pyflakes-0.8.1): Remove variable.
(python-pyflakes-1.2): New variable.
* gnu/packages/openstack.scm (python-hacking)[propagated-inputs]: Replace
python-pyflakes-0.8.1 with python-pyflakes-1.2.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/openstack.scm2
-rw-r--r--gnu/packages/python-xyz.scm37
2 files changed, 22 insertions, 17 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 8dd8c1907c..6c81454150 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -144,7 +144,7 @@ manner.")
        ("python-mccabe-0.2.1" ,python-mccabe-0.2.1)
        ("python-pbr" ,python-pbr)
        ("python-pep8-1.5.7" ,python-pep8-1.5.7)
-       ("python-pyflakes-0.8.1" ,python-pyflakes-0.8.1)
+       ("python-pyflakes-1.2" ,python-pyflakes-1.2)
        ("python-six" ,python-six)))
     (native-inputs
      `( ;; Tests
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c6c6bf2c3e..80185f49e0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7380,6 +7380,27 @@ PEP 8.")
 (define-public python2-pyflakes
   (package-with-python2 python-pyflakes))
 
+;; Flake8 2.6 requires an older version of pyflakes.
+;; This should be removed ASAP.
+(define-public python-pyflakes-1.2
+  (package (inherit python-pyflakes)
+    (version "1.2.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pyflakes" version))
+       (sha256
+        (base32
+         "17hkw8yd44cr8fz13phy4aih3r5j2p7ild4zlvqdh2c8dmiinjif"))))
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         ;; This one test fails.
+         (replace 'check
+           (lambda _ (invoke "pytest" "-vv" "-k" "not test_f_string"))))))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)))))
+
 (define-public python-mccabe
   (package
     (name "python-mccabe")
@@ -7438,22 +7459,6 @@ complexity of Python source code.")
 (define-public python2-pep8-1.5.7
   (package-with-python2 python-pep8-1.5.7))
 
-;; Flake8 2.4.1 requires an older version of pyflakes.
-;; This should be removed ASAP.
-(define-public python-pyflakes-0.8.1
-  (package (inherit python-pyflakes)
-    (version "0.8.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "pyflakes" version))
-       (sha256
-        (base32
-         "0sbpq6pqm1i9wqi41mlfrsc5rk92jv4mskvlyxmnhlbdnc80ma1z"))))
-    (arguments
-     ;; XXX Tests not compatible with Python 3.5.
-     '(#:tests? #f))))
-
 (define-public python-flake8
   (package
     (name "python-flake8")