summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2020-04-26 11:24:32 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-04-28 17:27:47 +0200
commitb3d04190f4ebbba9a7879ad72443ea6bf216ba76 (patch)
tree88f062933dad6061744a22e376c568a83ef45164 /gnu
parent085948fbfc8aef4370d8df8784bbd239c333fa99 (diff)
downloadguix-b3d04190f4ebbba9a7879ad72443ea6bf216ba76.tar.gz
gnu: Add emacs-toml-mode.
* gnu/packages/emacs-xyz.scm (emacs-toml-mode): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0ae3f72fb7..b2da56f34d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2584,6 +2584,30 @@ strings.")
 Stack Overflow, Super User, and other StackExchange sites.")
       (license license:gpl3+))))
 
+(define-public emacs-toml-mode
+  (let ((version "0.1.3")
+        (revision "0")
+        (commit "f6c61817b00f9c4a3cab1bae9c309e0fc45cdd06"))
+    (package
+      (name "emacs-toml-mode")
+      (version (git-version version revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/dryman/toml-mode.el.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "05b4ksay85c8y5ncax0qsvnmplwsfiw24z16a58gkarjz938hb57"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/dryman/toml-mode.el")
+      (synopsis "Emacs major mode for editing TOML files")
+      (description
+       "This package provides a major mode for editing files in @acronym{TOML,
+Tom's Obvious, Minimal Language} data format.")
+      (license license:gpl3+))))
+
 (define-public emacs-f
   (package
     (name "emacs-f")