summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-14 16:38:06 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-15 15:38:51 +0100
commitb4aee31dcb3a926109a185df055e780116867fcc (patch)
tree0a2f88138dc8428069536c2e66fca63087510e6f /gnu
parentb4a22ccaaadb0934e4a44aeb25609d8abdac998b (diff)
downloadguix-b4aee31dcb3a926109a185df055e780116867fcc.tar.gz
gnu: Add r-cytolib.
* gnu/packages/bioconductor.scm (r-cytolib): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 894a150624..796543f7c0 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -5264,6 +5264,26 @@ and to both short and long sequence reads.")
 cluster count and membership by stability evidence in unsupervised analysis.")
     (license license:gpl2)))
 
+(define-public r-cytolib
+  (package
+    (name "r-cytolib")
+    (version "1.8.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "cytolib" version))
+       (sha256
+        (base32
+         "1zk5i09k782lw6297gl3rh0g4fxswr2ang8dgqj7p0814l7h15k9"))))
+    (properties `((upstream-name . "cytolib")))
+    (build-system r-build-system)
+    (home-page "https://bioconductor.org/packages/cytolib/")
+    (synopsis "C++ infrastructure for working with gated cytometry")
+    (description
+     "This package provides the core data structure and API to represent and
+interact with gated cytometry data.")
+    (license license:artistic2.0)))
+
 (define-public r-flowcore
   (package
     (name "r-flowcore")