summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-04 01:11:47 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-04 18:03:44 +0100
commit53244d1ffa544305d4b6c19907dfcaf2bff2fd21 (patch)
treec71a80f811cf8d6ff36f16cc83d1029202c0eb15 /gnu
parent95943ed7dca205e81c22cd0723a3ab1ba67d4040 (diff)
downloadguix-53244d1ffa544305d4b6c19907dfcaf2bff2fd21.tar.gz
gnu: cloc: Update phase style.
* gnu/packages/code.scm (cloc)[arguments]: Substitute INVOKE for SYSTEM*
and end phases with #t.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/code.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 4a63cba7a0..8d9c661302 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -229,13 +229,13 @@ COCOMO model or user-provided parameters.")
                   (replace 'install
                     (lambda* (#:key inputs outputs #:allow-other-keys)
                       (let* ((out (assoc-ref outputs "out")))
-                        (zero?
-                         (system* "make" "-C" "Unix"
-                                  (string-append "prefix=" out)
-                                  (string-append "INSTALL="
-                                                 (assoc-ref inputs "coreutils")
-                                                 "/bin/install")
-                                  "install")))))
+                        (invoke "make" "-C" "Unix"
+                                (string-append "prefix=" out)
+                                (string-append "INSTALL="
+                                               (assoc-ref inputs "coreutils")
+                                               "/bin/install")
+                                "install")
+                        #t)))
                   (add-after 'install 'wrap-program
                     (lambda* (#:key inputs outputs #:allow-other-keys)
                       (let ((out (assoc-ref outputs "out")))