summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-12-12 00:42:32 +0100
committerLudovic Courtès <ludo@gnu.org>2016-12-12 00:42:32 +0100
commit92cc9cf180213439374bf88f0782c5c087b751f7 (patch)
treef8f988806d04d033c4b8f96dc758ca4f6e44ab48 /gnu
parent78636f0b8ce0fa7c3483a378ef31832f38a3d19a (diff)
downloadguix-92cc9cf180213439374bf88f0782c5c087b751f7.tar.gz
gnu: guile: Update to 2.0.13.
* gnu/packages/guile.scm (guile-2.0): Update to 2.0.13.
[source](patches): New field.
[replacement]: Remove.
(guile-2.0.13): Remove.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile.scm19
1 files changed, 3 insertions, 16 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 4572544ec3..dffa1258d2 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -133,15 +133,15 @@ without requiring the source code to be rewritten.")
 (define-public guile-2.0
   (package
    (name "guile")
-   (version "2.0.12")
-   (replacement guile-2.0.13)                 ;CVE-2016-8606 and CVE-2016-8605
+   (version "2.0.13")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/guile/guile-" version
                                 ".tar.xz"))
             (sha256
              (base32
-              "1sdpjq0jf1h65w29q0zprj4x6kdp5jskkvbnlwphy9lvdxrqg0fy"))))
+              "12yqkr974y91ylgw6jnmci2v90i90s7h9vxa4zk0sai8vjnz4i1p"))
+            (patches (search-patches "guile-repl-server-test.patch"))))
    (build-system gnu-build-system)
    (native-inputs `(("pkgconfig" ,pkg-config)))
    (inputs `(("libffi" ,libffi)
@@ -207,19 +207,6 @@ without requiring the source code to be rewritten.")
     (properties '((hidden? . #t)))          ;people should install 'guile-2.0'
     (replacement #f)))
 
-(define guile-2.0.13
-  (package
-    (inherit guile-2.0)
-    (version "2.0.13")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://gnu/guile/guile-" version
-                                  ".tar.xz"))
-              (sha256
-               (base32
-                "12yqkr974y91ylgw6jnmci2v90i90s7h9vxa4zk0sai8vjnz4i1p"))
-              (patches (search-patches "guile-repl-server-test.patch"))))))
-
 (define-public guile-next
   (package (inherit guile-2.0)
     (name "guile-next")