summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-08-20 16:08:27 +0200
committerLudovic Courtès <ludo@gnu.org>2018-08-20 16:32:18 +0200
commit0ec3800274dd5871059b0a508d45247072dd3d9e (patch)
treee6562ca7d4488ebc017ef76942ca4fb8162fbbf9 /gnu
parent45c01189cca2c9c7852eb1bc24e3cd892906c912 (diff)
downloadguix-0ec3800274dd5871059b0a508d45247072dd3d9e.tar.gz
gnu: guile-json: Update to 1.1.1.
* gnu/packages/guile.scm (guile-json): Update to 1.1.1.
[source]: Remove snippet.
[native-inputs]: Add PKG-CONFIG.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile.scm18
1 files changed, 3 insertions, 15 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 358613bd65..30d2e2612c 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -906,7 +906,7 @@ for Guile\".")
 (define-public guile-json
   (package
     (name "guile-json")
-    (version "1.0.1")
+    (version "1.1.1")
     (home-page "https://github.com/aconchillo/guile-json")
     (source (origin
               (method url-fetch)
@@ -915,23 +915,11 @@ for Guile\".")
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "16155dv30rhagz6dwv7xc87l386i8v0f1kgydqa2ajr166fi9qhr"))
-              (modules '((guix build utils)))
-              (snippet
-               ;; Make sure everything goes under .../site/X.Y, like Guile's
-               ;; search paths expects.
-               '(begin
-                  (substitute* "configure.ac"
-                    (("GUILE_PROGS")
-                     (string-append "GUILE_PROGS\n"
-                                    "AC_SUBST([GUILE_EFFECTIVE_VERSION])\n")))
-                  (substitute* '("Makefile.am" "json/Makefile.am")
-                    (("moddir[[:blank:]]*=.*/share/guile/site" all)
-                     (string-append all "/@GUILE_EFFECTIVE_VERSION@")))
-                  #t))))
+                "12jqkn9qgwdlxbasy2n25a2a7apf30dww1nnxqfam5735k3jdngv"))))
     (build-system gnu-build-system)
     (native-inputs `(("autoconf" ,autoconf)
                      ("automake" ,automake)
+                     ("pkg-config" ,pkg-config)
                      ("guile" ,guile-2.2)))
     (inputs `(("guile" ,guile-2.2)))
     (synopsis "JSON module for Guile")