summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-08-10 12:40:49 -0400
committerLeo Famulari <leo@famulari.name>2020-08-21 17:59:38 -0400
commit1bc275034fe8070c720ca341db2d9588480aa044 (patch)
treefed2a7a4a976f5be208923b580a01446fd83fdfc /gnu
parentc02398edf43c393b858d57c7b9e4839514f85acb (diff)
downloadguix-1bc275034fe8070c720ca341db2d9588480aa044.tar.gz
gnu: Use a descriptive file-name for linux-libre deblobbing scripts.
Fixes <https://bugs.gnu.org/42789>.

* gnu/packages/linux.scm (linux-libre-deblob-scripts): Set the file-name of the
deblob and deblob-check scripts.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index afe8d2ade5..1ad38a63c4 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -194,12 +194,16 @@ defconfig.  Return the appropriate make target if applicable, otherwise return
           (uri (string-append "https://linux-libre.fsfla.org"
                               "/pub/linux-libre/releases/" version "-gnu/"
                               "deblob-" (version-major+minor version)))
+          (file-name (string-append "linux-libre-deblob-"
+                                    (version-major+minor version)))
           (sha256 deblob-hash))
         (origin
           (method url-fetch)
           (uri (string-append "https://linux-libre.fsfla.org"
                               "/pub/linux-libre/releases/" version "-gnu/"
                               "deblob-check"))
+          (file-name (string-append "linux-libre-deblob-check-"
+                                    (version-major+minor version)))
           (sha256 deblob-check-hash))))
 
 (define deblob-scripts-5.8