summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-06-07 21:53:34 +0800
committer宋文武 <iyzsong@gmail.com>2016-06-11 12:53:09 +0800
commit1c4c8a33d7a6ab166559ea281b7f96c2e04bebc7 (patch)
tree2678ce7ca391e9f4b3a0c5b1aa124f796129fb89 /gnu
parentd951bd547cd9aadb16c1d324985055822cee50fc (diff)
downloadguix-1c4c8a33d7a6ab166559ea281b7f96c2e04bebc7.tar.gz
gnu: Add python-kazoo and python2-kazoo.
* gnu/packages/python.scm (python-kazoo, python2-kazoo): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 70e44416c9..acdf4b31b7 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9069,3 +9069,30 @@ data in Python.")
 
 (define-public python2-tabulate
   (package-with-python2 python-tabulate))
+
+(define-public python-kazoo
+  (package
+    (name "python-kazoo")
+    (version "2.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "kazoo" version))
+       (sha256
+        (base32
+         "10pb864if9qi2pq9lfb9m8f7z7ss6rml80gf1d9h64lap5crjnjj"))))
+    (build-system python-build-system)
+    (arguments '(#:tests? #f)) ; XXX: needs zookeeper
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)
+       ("python-six" ,python-six)))
+    (home-page "https://kazoo.readthedocs.org")
+    (synopsis "High-level Zookeeper client library")
+    (description
+     "Kazoo is a Python client library for the Apache Zookeeper distributed
+application service.  It is designed to be easy to use and to avoid common
+programming errors.")
+    (license asl2.0)))
+
+(define-public python2-kazoo
+  (package-with-python2 python-kazoo))