summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-06-04 17:55:56 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2017-06-08 19:14:05 +0200
commit1e0ae3b352d4521aa2a88158ab49277cea7cd0bd (patch)
tree5fb148ba040d23e4b1e2e69f301032a6bc1066d6 /gnu
parented4a3ec68c24693fcefe8ca7c1f55d62cc5bf482 (diff)
downloadguix-1e0ae3b352d4521aa2a88158ab49277cea7cd0bd.tar.gz
gnu: kde.scm, kde-frameworks.scm: Add and update comments.
* gnu/packages/kde-frameworks.scm
  (kpackage,plasma-framework)[arguments]: Update comment (number of failed
  tests).
  (kdeclarative)[arguments]<#:phases>: Update comment.
  (bluez-qt,knotifications,kpty,ktexteditor,ktextwidgets,solid)[inputs]: Add a
  todo comment.
  (kguiaddons): Add a todo comment.
  (phonon)[native-inputs]: Add a todo comment.
* gnu/packages/kde-frameworks.scm (kauth)[arguments]<#:phases>: Add a todo
  comment.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm23
-rw-r--r--gnu/packages/kde.scm2
2 files changed, 21 insertions, 4 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 18e445e215..8fe71d5b5d 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -123,6 +123,8 @@ common build settings used in software produced by the KDE community.")
                 "177647r2jqfm32hqcz2nqfqv6v48hn5ab2vc31svba2wz23fkgk7"))))
     (build-system cmake-build-system)
     (native-inputs
+     ;; TODO: Add qttools to build the Qt Designer plugin.
+     ;; TODO: Think about adding pulseaudio. Is it required for sound?
      `(("extra-cmake-modules" ,extra-cmake-modules)))
     (inputs
      `(("qtbase" ,qtbase)))
@@ -296,6 +298,7 @@ http://freedesktop.org/wiki/Specifications/open-collaboration-services/")
      `(("dbus" ,dbus)
        ("extra-cmake-modules" ,extra-cmake-modules)))
     (inputs
+     ;; TODO: qtdeclarative (yields one failing test)
      `(("qtbase" ,qtbase)))
     (arguments
      `(#:configure-flags
@@ -643,6 +646,10 @@ infrastructure.")
                (base32
                 "1nmlwvy2jdmh0m6bmahvk68vl2rs9s28c10dkncpi6gvhsdkigqx"))))
     (build-system cmake-build-system)
+    ;; TODO: Build packages for the Python bindings.  Ideally this will be
+    ;; done for all versions of python guix supports.  Requires python,
+    ;; python-sip, clang-python, libclang.  Requires python-2 in all cases for
+    ;; clang-python.
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
        ("pkg-config" ,pkg-config)))
@@ -1193,6 +1200,7 @@ which are used in DBus communication.")
     (inputs
      `(("qtbase" ,qtbase)
        ("udev" ,eudev)))
+    ;; TODO: Add runtime-only dependency MediaPlayerInfo
     (home-page "https://community.kde.org/Frameworks")
     (synopsis "Desktop hardware abstraction")
     (description "Solid is a device integration framework.  It provides a way of
@@ -1573,6 +1581,9 @@ asynchronous jobs.")
        ("kwindowsystem" ,kwindowsystem)
        ("phonon" ,phonon)
        ("qtbase" ,qtbase)
+       ;; TODO: qtspeech (new in Qt 5.9)
+       ;; TODO: Think about adding dbusmenu-qt5 from
+       ;; https://launchpad.net/libdbusmenu-qt
        ("qtx11extras" ,qtx11extras)))
     (arguments
      `(#:phases
@@ -1615,7 +1626,7 @@ covers feedback and persistent events.")
        ("ki18n" ,ki18n)
        ("qtbase" ,qtbase)))
     (arguments
-     `(#:tests? #f ; FIXME: 1/4 tests fail.
+     `(#:tests? #f ; FIXME: 3/9 tests fail.
        #:phases
        (modify-phases %standard-phases
          (add-before 'check 'check-setup
@@ -1648,6 +1659,7 @@ were traditional plugins.")
     (inputs
      `(("kcoreaddons" ,kcoreaddons)
        ("ki18n" ,ki18n)
+       ;; TODO: utempter, for managing UTMP entries
        ("qtbase" ,qtbase)))
     (arguments
      `(#:tests? #f ; FIXME: 1/1 tests fail.
@@ -2013,7 +2025,8 @@ their settings.")
        (modify-phases %standard-phases
          (add-before 'check 'start-xorg-server
            (lambda* (#:key inputs #:allow-other-keys)
-             ;; The test suite requires a running X server.
+             ;; The test suite requires a running X server, setting
+             ;; QT_QPA_PLATFORM=offscreen does not suffice.
              (system (string-append (assoc-ref inputs "xorg-server")
                                     "/bin/Xvfb :1 -screen 0 640x480x24 &"))
              (setenv "DISPLAY" ":1")
@@ -2695,7 +2708,8 @@ types or handled by application specific code.")
      `(("extra-cmake-modules" ,extra-cmake-modules)
        ("pkg-config" ,pkg-config)))
     (inputs
-     `(("karchive" ,karchive)
+     `(;; TODO: editor-config
+       ("karchive" ,karchive)
        ("kauth" ,kauth)
        ("kbookmarks" ,kbookmarks)
        ("kcodecs" ,kcodecs)
@@ -2774,6 +2788,7 @@ library.")
        ("kservice" ,kservice)
        ("kwidgetsaddons" ,kwidgetsaddons)
        ("kwindowsystem" ,kwindowsystem)
+       ;; TODO: qtspeech (new in Qt 5.9)
        ("qtbase" ,qtbase)))
     (arguments
      `(#:phases
@@ -2978,7 +2993,7 @@ setUrl, setUserAgent and call.")
        ("qtx11extras" ,qtx11extras)
        ("solid" ,solid)))
     (arguments
-     `(#:tests? #f ; FIXME: 13/14 tests fail.
+     `(#:tests? #f ; FIXME: 9/15 tests fail.
        #:phases
        (modify-phases %standard-phases
          (add-before 'check 'check-setup
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index b481bb98db..a5ad8da062 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -293,6 +293,8 @@ used in KDE development tools Kompare and KDevelop.")
        (modify-phases %standard-phases
          (add-before 'configure 'patch-cmakelists
            (lambda _
+             ;; TODO: Verify: This should no longer be necessary, since
+             ;; KF5AuthConfig.cmake.in contains this already.
              (substitute* "processcore/CMakeLists.txt"
                (("KAUTH_HELPER_INSTALL_DIR") "KDE_INSTALL_LIBEXECDIR"))))
          (replace 'check