summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-06-24 10:35:56 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-06-24 10:35:56 +0300
commit2d84ef328cfa19743d97dde5929ec2d5fc00f12e (patch)
tree062bdad37462f014d8e4d4467c479fa05bfdf930 /gnu
parentd5c0b3fa7e01c57cd7fa66be95f7ca8a02417c00 (diff)
downloadguix-2d84ef328cfa19743d97dde5929ec2d5fc00f12e.tar.gz
gnu: ocaml4.07-piqi: Don't use unstable tarball.
* gnu/packages/ocaml.scm (ocaml4.07-piqi)[source]: Download using
git-fetch.
[arguments]: Add custom phase to make files writable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index d9ba2aee2d..5792c1f465 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2940,13 +2940,14 @@ and 4 (random based) according to RFC 4122.")
     (name "ocaml4.07-piqi")
     (version "0.7.7")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/alavrik/piqi-ocaml/"
-                                  "archive/v" version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/alavrik/piqi-ocaml")
+                     (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1l0b4saxmwqgw9mb10mwrz31lvpj3l0abh3cwarqp0x4vdrzshbh"))))
+                "1913jpsb8mvqi8609j4g4sm5jhg50dq0xqxgy8nmvknfryyc89nm"))))
     (build-system ocaml-build-system)
     (arguments
      `(#:make-flags
@@ -2955,6 +2956,10 @@ and 4 (random based) according to RFC 4122.")
                             "/bin/sh"))
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'make-files-writable
+           (lambda _
+             (for-each make-file-writable (find-files "."))
+             #t))
          (delete 'configure))
        #:ocaml ,ocaml-4.07
        #:findlib ,ocaml4.07-findlib))