summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-06-18 13:45:16 -0400
committerKei Kebreau <kei@openmailbox.org>2017-06-20 19:50:27 -0400
commit2f6e988da368a1c2d971a4bdeff6ac9800a982af (patch)
tree2fd36fabe0b38d42503337f55d3a322d68b50425 /gnu
parent7357fcf286a9b11baad9798a106f21f8038db4ba (diff)
downloadguix-2f6e988da368a1c2d971a4bdeff6ac9800a982af.tar.gz
gnu: Add dos2unix.
* gnu/packages/textutils.scm (dos2unix): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/textutils.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 152d080599..e8ae30cd6d 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -11,6 +11,7 @@
 ;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
 ;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2017 Kei Kebreau <kei@openmailbox.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -39,6 +40,7 @@
   #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages gettext)
   #:use-module (gnu packages java)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages perl)
@@ -47,6 +49,34 @@
   #:use-module (gnu packages readline)
   #:use-module (gnu packages slang))
 
+(define-public dos2unix
+  (package
+    (name "dos2unix")
+    (version "7.3.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://waterlan.home.xs4all.nl/" name "/"
+                           name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1i9hbxn0br7xa18z4bjpkdv7mrzmbfxhm44mzpd07yd2qnxsgkcc"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:make-flags (list "CC=gcc"
+                          (string-append "prefix=" (assoc-ref %outputs "out")))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)))) ; no configure script
+    (native-inputs
+     `(("gettext" ,gettext-minimal)
+       ("perl" ,perl)))
+    (home-page "https://waterlan.home.xs4all.nl/dos2unix.html")
+    (synopsis "DOS/Mac to Unix and vice versa text file format converter")
+    (description
+     "dos2unix is a tool to convert line breaks in a text file from Unix format
+to DOS format and vice versa.")
+    (license license:bsd-2)))
+
 (define-public recode
   (package
     (name "recode")