summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-24 12:16:54 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-26 02:16:58 +0200
commit55492129f55116acfe8ab42aefd00fa829c3ac58 (patch)
treea2a717df20badc3f0e11a52de2c1af0f47be07bb /gnu
parentbc884ed8abc6075cfb2fa239154d43156cc5edea (diff)
downloadguix-55492129f55116acfe8ab42aefd00fa829c3ac58.tar.gz
gnu: sendmail: Return #t from all phases.
* gnu/packages/mail.scm (sendmail)[arguments]: Substitute INVOKE for
SYSTEM*. Return #t rather than undefined from phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mail.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index fef7bc39c5..d7963db383 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1955,14 +1955,15 @@ define(`confLIBS', `-lresolv')
 define(`confINSTALL', `~a/devtools/bin/install.sh')
 define(`confDEPEND_TYPE', `CC-M')
 define(`confINST_DEP', `')
-" (getcwd))))))
+" (getcwd))))
+             #t))
          (replace 'build
            (lambda _
-             (and (zero? (system* "sh" "Build"))
-                  (with-directory-excursion "cf/cf"
-                    (begin
-                      (copy-file "generic-linux.mc" "sendmail.mc")
-                      (zero? (system* "sh" "Build" "sendmail.cf")))))))
+             (invoke "sh" "Build")
+             (with-directory-excursion "cf/cf"
+               (copy-file "generic-linux.mc" "sendmail.mc")
+               (invoke "sh" "Build" "sendmail.cf"))
+             #t))
          (add-before 'install 'pre-install
            (lambda _
              (let ((out (assoc-ref %outputs "out")))
@@ -1971,7 +1972,8 @@ define(`confINST_DEP', `')
                (mkdir-p (string-append out "/etc/mail"))
                (setenv "DESTDIR" out)
                (with-directory-excursion "cf/cf"
-                 (zero? (system* "sh" "Build" "install-cf")))))))
+                 (invoke "sh" "Build" "install-cf"))
+               #t))))
        ;; There is no make check.  There are some post installation tests, but those
        ;; require root privileges
        #:tests? #f))