summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-07-05 12:33:50 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-07-05 12:37:03 +0200
commit7af213fefe3608a80c9f0a7e91f0c79051aff16f (patch)
treeb002ff0fe73af70443640f14ee1201fba4390509 /gnu
parentec982546941b59fdd14e0b08f023baf2e75d71a3 (diff)
downloadguix-7af213fefe3608a80c9f0a7e91f0c79051aff16f.tar.gz
gnu: Add sbcl-dbus.
* gnu/packages/lisp.scm (sbcl-dbus): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 64e5a16939..c05ec715cb 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -6608,3 +6608,39 @@ also makes it easy to shift paradigms when necessary - the usual Lisp control
 constructs can be used interchangeably with pattern matching, and the full
 power of CXML is available when necessary.")
     (license #f)))
+
+(define-public sbcl-dbus
+  (let ((commit "24b452df3a45ca5dc95015500f34baad175c981a")
+        (revision "1"))
+    (package
+      (name "sbcl-dbus")
+      (build-system asdf-build-system/sbcl)
+      (version (git-version "20190408" revision commit))
+      (home-page "https://github.com/death/dbus")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url home-page)
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0fw2q866yddbf23nk9pxphm9gsasx35vjyss82xzvndnjmzlqfl5"))))
+      (inputs
+       `(("alexandria" ,sbcl-alexandria)
+         ("trivial-garbage" ,sbcl-trivial-garbage)
+         ("babel" ,sbcl-babel)
+         ("iolib" ,sbcl-iolib)
+         ("iolib+multiplex" ,sbcl-iolib+multiplex)
+         ("iolib+syscalls" ,sbcl-iolib+syscalls)
+         ("iolib+streams" ,sbcl-iolib+streams)
+         ("iolib+sockets" ,sbcl-iolib+sockets)
+         ("ieee-floats" ,sbcl-ieee-floats)
+         ("flexi-streams" ,sbcl-flexi-streams)
+         ("cl-xmlspam" ,sbcl-cl-xmlspam)
+         ("ironclad" ,sbcl-ironclad)))
+      (synopsis "D-Bus client library for Common Lisp")
+      (description "This is a Common Lisp library that allows to publish D-Bus
+objects as well as send and notify other objects connected to a bus.")
+      (license license:bsd-2))))