summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-02-15 15:48:27 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-15 22:02:54 +0100
commit87d3e94d82111081a40ed2bea76e50575967af30 (patch)
treee67fb110adcd4949f88b823cba10c06f14980d1a /gnu
parent6388bed78cf6e9126b53e2a2ef832765a0373ab7 (diff)
downloadguix-87d3e94d82111081a40ed2bea76e50575967af30.tar.gz
gnu: efibootmgr: Remove obsolete workaround.
* gnu/packages/linux.scm (efibootmgr)[arguments]: Don't set C_INCLUDE_PATH in
 #:configure-flags.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 1 insertions, 6 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 2bf7b4bee9..e9a6675839 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5095,12 +5095,7 @@ interface to the variable facility of UEFI boot firmware.")
                           ;; installed (known as OS_VENDOR in the code).
                           ;; GRUB overrides this, as such it's only used if
                           ;; nothing else is specified on the command line.
-                          "EFIDIR=gnu"
-                          ;; Treat kernel headers as system headers to prevent
-                          ;; warnings about conflicting types.
-                          (string-append "C_INCLUDE_PATH="
-                                         (assoc-ref %build-inputs "kernel-headers")
-                                         "/include"))
+                          "EFIDIR=gnu")
        #:phases (modify-phases %standard-phases (delete 'configure))))
     (native-inputs
      `(("pkg-config" ,pkg-config)))