summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-11-12 18:33:45 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2016-11-13 13:34:00 +0100
commit917239ff99468de351f93a019e9abe52f29adec7 (patch)
tree7b364ae2b95c23ec63ab57ac2d0d0aaecde858d6 /gnu
parent3b0ac7950057a99cde7a973387e1fe8a13db5518 (diff)
downloadguix-917239ff99468de351f93a019e9abe52f29adec7.tar.gz
gnu: tidy: Use ‘modify-phases’.
* gnu/packages/web.scm (tidy)[arguments]: Use the ‘modify-phases’ syntax.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 5237cc7b9e..6cffc79db1 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -510,15 +510,14 @@ UTS#46.")
               (patches (search-patches "tidy-CVE-2015-5522+5523.patch"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases (alist-cons-after
-                 'unpack 'bootstrap
-                 (lambda* (#:key inputs #:allow-other-keys)
-                   ;; configure.in and Makefile.am aren't in the root of the
-                   ;; source tree.
-                   (copy-recursively "build/gnuauto" ".")
-                   (setenv "AUTOMAKE" "automake --foreign")
-                   (zero? (system* "autoreconf" "-vfi")))
-                 %standard-phases)))
+     '(#:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'bootstrap
+                    (lambda* (#:key inputs #:allow-other-keys)
+                      ;; configure.in and Makefile.am aren't in the root of the
+                      ;; source tree.
+                      (copy-recursively "build/gnuauto" ".")
+                      (setenv "AUTOMAKE" "automake --foreign")
+                      (zero? (system* "autoreconf" "-vfi")))))))
     (native-inputs
      `(("automake" ,automake)
        ("autoconf" ,autoconf)