summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-11-07 15:35:22 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-11-07 23:32:42 +0100
commit96a392a0b2511bcea94f382b1dd36a189b3f856e (patch)
treeb7bdd5b54fac5a3f855e98f28ed50850d2789b4e /gnu
parent60faf945979a4122dd877a3e727f0bae708c6d97 (diff)
downloadguix-96a392a0b2511bcea94f382b1dd36a189b3f856e.tar.gz
gnu: Add r-gprofiler.
* gnu/packages/bioinformatics.scm (r-gprofiler): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index ba248578b0..f130d71327 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9768,6 +9768,30 @@ views.  High-level plots include sequence fragment length, edge-linked
 interval to data view, mismatch pileup, and several splicing summaries.")
     (license license:artistic2.0)))
 
+(define-public r-gprofiler
+  (package
+    (name "r-gprofiler")
+    (version "0.6.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "gProfileR" version))
+       (sha256
+        (base32
+         "1qix15d0wa9nspdclcawml94mng4qmr2jciv7d24py315wfsvv8p"))))
+    (properties `((upstream-name . "gProfileR")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-plyr" ,r-plyr)
+       ("r-rcurl" ,r-rcurl)))
+    (home-page "http://cran.r-project.org/web/packages/gProfileR/")
+    (synopsis "Interface to the g:Profiler toolkit")
+    (description
+     "This package provides tools for functional enrichment analysis,
+gene identifier conversion and mapping homologous genes across related
+organisms via the @code{g:Profiler} toolkit.")
+    (license license:gpl2+)))
+
 (define-public r-qvalue
   (package
     (name "r-qvalue")