summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-18 14:05:29 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-01-07 17:18:16 +0100
commitbc899123e75f1cbdca36843396d7a0b7b18c69b8 (patch)
treecc7b7f5b358152d98a8515e1bebbb73c4e58827f /gnu
parent6b82f56cf9dc1674333a6f246663dac6195138c3 (diff)
downloadguix-bc899123e75f1cbdca36843396d7a0b7b18c69b8.tar.gz
gnu: Add snow.
* gnu/packages/statistics.scm (r-snow): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index f75950db8a..38bd649dd6 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1643,3 +1643,24 @@ convenient and easy to use replacement for @code{cat} and @code{print}
 statements.")
     (license license:lgpl3+)))
 
+(define-public r-snow
+  (package
+    (name "r-snow")
+    (version "0.4-1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "snow" version))
+              (sha256
+               (base32
+                "19r2yq8aqw99vwyx81p6ay4afsfqffal1wzvizk3dj882s2n4j8w"))))
+    (build-system r-build-system)
+    (home-page "http://cran.r-project.org/web/packages/snow")
+    (synopsis "Support for simple parallel computing in R")
+    (description
+     "The snow package provides support for simple parallel computing on a
+network of workstations using R.  A master R process calls @code{makeCluster}
+to start a cluster of worker processes; the master process then uses functions
+such as @code{clusterCall} and @code{clusterApply} to execute R code on the
+worker processes and collect and return the results on the master.")
+    (license (list license:gpl2+ license:gpl3+))))
+