summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-12 23:30:17 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-24 21:54:31 +0200
commitc5c55a9f2c607eca1f7649026b591284c116b141 (patch)
tree3ed3f2f996b2e9e60b00528c341f52deaef9958a /gnu
parent9d0c291e3e6d226cdfd4cebee0a389ad24fa748f (diff)
downloadguix-c5c55a9f2c607eca1f7649026b591284c116b141.tar.gz
gnu: Add python-sphinxcontrib-serializinghtml.
* gnu/packages/sphinx.scm (python-sphinxcontrib-serializinghtml): New public
variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/sphinx.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 28925a0492..9af080663f 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -153,6 +153,26 @@ commands into documents, helping you to keep your command examples up to date.")
 (define-public python2-sphinxcontrib-programoutput
   (package-with-python2 python-sphinxcontrib-programoutput))
 
+(define-public python-sphinxcontrib-serializinghtml
+  (package
+    (name "python-sphinxcontrib-serializinghtml")
+    (version "1.1.3")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "sphinxcontrib-serializinghtml" version))
+              (sha256
+               (base32
+                "09sj3nwahwr4iymg86gczbh151cfczqhf2kclbblzh2jh0zv7vy0"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f))                    ;XXX: circular dependency on Sphinx
+    (home-page "https://github.com/sphinx-doc/sphinxcontrib-serializinghtml")
+    (synopsis "Sphinx extension to serialize HTML files")
+    (description
+     "@code{sphinxcontrib-serializinghtml} is a Sphinx extension which outputs
+\"serialized\" HTML files.")
+    (license license:bsd-2)))
+
 (define-public python-sphinxcontrib-svg2pdfconverter
   (package
     (name "python-sphinxcontrib-svg2pdfconverter")