summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-13 11:15:32 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-13 12:49:21 +0200
commitca12352a3e8297fa015b099c7e395b6d7795aa6b (patch)
tree2d9fe4b5a3f486cfe44f1a371d178308c99642e0 /gnu
parentf3855bf634a81fe65998e624e9ca17374ad930da (diff)
downloadguix-ca12352a3e8297fa015b099c7e395b6d7795aa6b.tar.gz
gnu: ocaml-charinfo-width: Parameterize download url.
* gnu/packages/ocaml.scm (ocaml-charinfo-width)[source]: Don't hardcode
version number in source uri. Declare file-name.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 52896634ef..d820b855d8 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5,7 +5,7 @@
 ;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
 ;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
-;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016-2018 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2017 Ben Woodcroft <donttrustben@gmail.com>
 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -3045,7 +3045,9 @@ library is currently designed for Unicode Standard 3.2.")
     (version "1.1.0")
     (source (origin
               (method url-fetch)
-              (uri "https://bitbucket.org/zandoye/charinfo_width/get/1.1.0.tar.gz")
+              (uri (string-append "https://bitbucket.org/zandoye/charinfo_width"
+                                  "/get/" version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
                 "00bv4p1yqs8y0z4z07wd9w9yyv669dikp9b04dcjbwpiy2wy0086"))))