summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-09-26 11:23:48 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2017-10-13 13:53:48 +0200
commitcf7cf45a5fcd77a964c497299cd7bd60357f7758 (patch)
tree14f8cd83df646676aa9b26d6ca31045174bf9ef5 /gnu
parentbb4fcf7ba6c361f45215c0200515b7270d93dbdc (diff)
downloadguix-cf7cf45a5fcd77a964c497299cd7bd60357f7758.tar.gz
gnu: kio: Symlink some files referred to by different names.
* gnu/package/kde-frameworks.scm (kio)[arguments]
  <#:phases>'add-symlinks': New phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 01cc4ee099..507ec196b4 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2460,7 +2460,16 @@ makes starting KDE applications faster and reduces memory consumption.")
              (setenv "XDG_RUNTIME_DIR" (getcwd))
              ;; make Qt render "offscreen", required for tests
              (setenv "QT_QPA_PLATFORM" "offscreen")
-             #t)))))
+             #t))
+         (add-after 'install 'add-symlinks
+           ;; Some package(s) (e.g. bluedevil) refer to these service types by
+           ;; the wrong name.  I would prefer to patch those packages, but I
+           ;; cannot find the files!
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((kst5 (string-append (assoc-ref outputs "out")
+                                        "/share/kservicetypes5/")))
+               (symlink (string-append kst5 "kfileitemactionplugin.desktop")
+                        (string-append kst5 "kfileitemaction-plugin.desktop"))))))))
     ;;(replace 'check
     ;;  (lambda _
     ;;    (setenv "DBUS_FATAL_WARNINGS" "0")